Lab2 (session 1 due Feb 15 and session 2 due Feb 22), EES6513, Hongjie Xie, Assistant Professor

(besides the questions you need to answer, I would like you copy and paste all the results after a major operation or step is finished) 
Topic: Spatial Data Analysis

Session 1, Vector data analysis
1. Copy 4 vector layers: cities, counties, intrstat, and states from C:\Program Files\ArcGIS\Bin\TemplateData\USA into your own directory (if you do not have yet, you can create one now). There are ways to copy GIS data:

(1). Use window explore

(2). Use ArcCatalog


Question 1: Please describe the differences by using these two ways and which one is the better one you should always use?
2. Create a new shapefile only cover the State of Texas based on “states” shapefile. Open ArcMap, and load those 4 layers and click ArcToolBox icon. Based on the lecture, we have 3 different groups of analysis tools to respectively deal with shapefile (or feature class), coverage, and raster. 

      Question 2: for shapefile (or feature class) data, using:



        For coverage data, using:

                          For raster data, using: 


To create a new shapefile of “State of Texas” based on the input file “states”, we have at least 3 difference ways to do it:

Way (1). Using ArcToolBox. I hope you know which group of tools you should use, since we are dealing with shape file now. I can tell you to use “select”, you will use a SQL query similar as the figure below, and save your output as “Texas1”.
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Way (2). Do not use ArcToolBox. Right click “states” in the table of content, click “Open Attribute Table”, and select record of Texas, right click “state”, click “Data\Export Data, save output to “Texas2”, click OK
Way (3). Do not use ArcToolBox. Right click “states”, click “Select\Clear Select Features”, to make sure nothing is selected now. Zone to Texas area. Click the “Select Features” icon, click Texas region in the map. You should see Texas is highlighted. Then right click “state”, click “Data\Export Data, save output to “Texas3”, click OK

3. Create a “Texas-cities” shapefile based on the “cities” shapefile. Now, you need to use the “clip” function (tool) in ArcToolBox to do this job. 
4. Create a “Texas-intrstate” shapefile based on “intrstat” and a “Texas-counties” shapefile based on “counties” shapefile. You will use the same tool to do the jobs as in step 3.

5. Create a map of Texas State with three counties (Frio, Bexar, and Kendall) inside.  
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To do this, you will first create a shapefile of the three counties, then you use the UNION tool in ArcToolBox to combine the shapefile with the Texas state shapefile you already. 


Question 3: Can you union one polygon shapefile with one polyline shapefile? Can you union one polygon shapefile with one point shapefile? Can you union the point shapefiles? Or polyline shapefiles?

6. Question 4: To make sure safety is the first priority to all residential and commercial areas, Texas Department of Transportation would like to check if there is any or how many of those areas are within 200 meters each side of all Texas major highway (intrstat). If you are the person to finish this project, what is your design by using the knowledge of GIS you learned from the class. Based on the data from this lab, you can at least create one very useful dataset for this project. Please create it and provide your design how to finish this project.
Session 2, Raster data analysis

Purposes: getting familiar with ArcGIS Spatial Analyst extension
This part is based on tutorials found in ESRI Visual Campus (campus.esri.com), "Using ArcGIS Spatial Analyst", and Bill Toll at Taylor University at http://www.css.tayloru.edu/~btoll/f03/312/res/r/Spatial.html.
Lab data: Copy two-entire directories Lab2 at (\\129.115.25.240\XIE_misc\EES6513) into your local computer (your user directory)
Start ArcMap and load the Spatial Analyst extension
From the Tools menu, choose Extensions. Make sure the box next to Spatial Analyst is checked, then click Close. If Spatial Analyst toolbar is not already displayed, from the View menu, choose Toolbars, then click Spatial Analyst. 

Part 1. Spatial Analyst for Insurance, Farmer, and Coffee Shop
Step 1.1.  Examine land use and flood zone
In this step, you will find residential parcels that are inside a flood zone area. 

Insurance companies examine flood zone areas to locate buildings and other assets susceptible to flood damage. Their predictions can be used to target insurance sales. Ideally, insurance companies would like to target individuals who perceive they are at risk to flooding, but in practice are unlikely to be flooded. This allows the insurance company to receive the premium but not pay any claims. Of course, this approach poses some issues of risk and ethics. 

Open Flood.mxd under Spatial-part1

Turn on the flood zone layer and notice that the flood zone affects many of the land use areas.

In the Table of Contents, highlight the Land use layer. On the Spatial Analyst toolbar, from the Spatial Analyst menu, choose Zonal Statistics. The Zonal Statistics dialog displays.

Make sure the Zone dataset is Land use. For Zone field, click Landuse_type2. For Value raster, click Flood zone. Uncheck Chart statistic, then click OK.

The resulting table should have four records, one for each land use type in the flood zone. Each field contains statistical information about that land use type's presence within the flood zone. 

Question 5:

Which land use types are in the flood zone? (  )

Which one has the greatest area in the flood zone?  (  )

Which land use type is most likely to contain homes?  (  )

Close the table

Step 1.2. Find the locations of the residential areas within the flood zone
You've identified that residential areas are located within the flood zone, but more detailed analysis is necessary to pinpoint the locations of those residential areas. Before the more detailed analysis, it is useful to create a diagram or flow chart of the layers and analysis functions you will use. For this analysis you will follow the steps shown in the flow chart below.


 
[image: image3.png]Flood zone

Land use

Query,

Residential

Query,

et homes|






First, you will query the Land use layer to create a new layer that contains only residential areas. You will then create another query to find the residential areas within the flood zone. The final results will be a new layer that you will call Wet homes.

1.2.1.  From the Spatial Analyst menu, choose Raster Calculator. The Raster Calculator displays. You will build an expression that queries the Land use layer for residential areas. 

Click the opening parenthesis button. Double-click Land use to add it to the expression box. Click the equals sign button to add a double equals sign (==) to the expression. Click the '3' button to add a 3 to the expression. Click the closing parenthesis button. Your final expression should be: ([Land use] == 3). 

Click Evaluate.

The expression is evaluated and a new layer is created that contains the results.
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Change the name of the new layer to Residential. Turn off the Flood zone and Land use layers so that only the Residential layer is visible. Values of 0 are not residential areas and values of 1 are residential areas.

Because you are interested only in the residential areas, you will remove the non-residential areas from the map.

Double-click the Residential layer to open its layer properties dialog. Click the Symbology tab. Click the symbol for 0, then click Remove. Click OK.

The Residential layer now displays only the residential areas.
1.2.2. You will query both the Flood zone and Residential layers. This operation is often called an overlay. The resulting layer will contain the residential and flood areas that overlap (or intersect) each other.

From the Spatial Analyst menu, choose Raster Calculator.

You will build an expression that selects areas in the Residential layer and in the Flood zone layer.

Build the following expression: [Flood zone] & [Residential]. (Hint: The ampersand stands for And.)

Click Evaluate.

A new layer is added to the Table of Contents. Change the name of the layer to Wet homes. Turn off the Residential layer.

Values of 1 are those areas that are both residential and in the flood zone. Use the layer properties dialog to remove the 0 values from the display as you did previously with the Residential layer.
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The resulting areas are the ones that an insurance company may want to target to sell flood insurance. City planners could also use this information for disaster planning services.

Save the map document.

Step 2. Isolate areas of high pH 
In this step, you will help a farmer balance the pH levels in a field that is being prepared for the next growing season. Some crops have better yields when the soils have a balanced pH level. Seven is a balanced pH level. Areas in the field with a pH less than seven are treated with lime (limestone) to raise the pH level. Areas with a pH above seven are treated with ammonium sulfate to lower the pH level. 

The farmer should not treat an entire field with all lime or all ammonium sulfate, but should locate areas of high and low pH and treat them accordingly (precision farming techniques). You will help the farmer find the areas that should be treated with ammonium sulfate (areas with pH greater than seven).

Open Farm.mxd under Spatial-part1
This map contains two layers. The Soil samples layer represents the soil samples that were collected in the field and tested for chemical composition. It contains several fields containing the chemical levels at each sample point. The Farm field layer represents the extent of the farmer's field.

For this analysis you will follow the steps shown in the flow chart below.
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You will interpolate a surface of pH values from the samples. You will then query the surface to find areas with pH greater than seven. The final results will be the areas the farmer needs to treat with ammonium sulfate.

In the Table of Contents, click the Soil samples layer to highlight it. From the Spatial Analyst menu, choose Interpolate to Raster, then click Inverse Distance Weighted.

The Inverse Distance Weighted dialog displays. For Input points, make sure Soil samples is specified. For Z value field, click PH. Accept the other defaults. Click OK.

The resulting surface is added to the Table of Contents. Rename the layer to pH surface. Turn off the Farm field layer so that you can see the surface. The dark green areas have low pH values, while the light pink areas have high pH values.

Next, you will isolate the high pH areas by creating a layer containing only areas with pH levels above seven.

From the Spatial Analyst menu, choose Raster Calculator. Create the following expression: [pH surface] > 7. Click Evaluate.

A new layer is added to the Table of Contents.

Change the name of the layer to pH Treatment Areas. Values of 1 are those areas that where pH is greater than seven. 

Use the layer properties dialog to remove the 0 values from the display as you did earlier with the Residential and Wet homes layers. Turn off the pH surface layer.

[image: image7.png]Farm.mxd - ArcHlap - Arclnfo

[_[OIx]

File Edit View Insett Selection Tools Window Help
DEE&+ Bex|o =& 72 &
egtor > | > [2]7] | 725 [Feaehenreaue =
SplilAnalst | Layer [ sutace B m
——
TF Loyers Q vetes
& B Soilsamples Q PP
20 Famfel - coeene
- o b R
= ENGIETEE— o
e S
= .
500 pHsutace @ .o
BLUE> » PN
5600245429-5.901 IR
s s0msized-s200 | M e
CIs200057137 -8.439t | LD
KT ——— O Y ¢ .
Dipay [Souce s s
L e | O |

[ [437968 44 5076320 25 Urkro |





The pH treatment areas are the areas that the farmer should treat with ammonium sulfate to lower the pH to seven so that it is balanced. The farm size is about 5.35 acres (233,046 square feet or 21,650 square meters) and the combined size of the newly defined treatment areas is about 0.145 acres (6,338 square feet or 588 square meters).

If the ammonium sulfate treatment costs $50.00 per acre, treating the entire 5.35 acres costs about $267.50, while treating 0.145 acres costs about $7.25. Treating only the areas that actually need it results in a possible savings of $260.25. Imagine if the farmer had several fields.

Farmers may use similar techniques when applying fertilizers and pesticides to their fields. Also, histories of crop yield and treatment can be mapped over time and used for future planning.

Save the map document.

Step 3. Examine coffee shops and their customers
In this step, you will examine existing coffee shops and their customers to find a good location for opening a new coffee shop.

In order to find a good location for a new shop, you will need to answer several questions: Is the new location too close to existing shops? Does the new location have similar characteristics to existing locations? Where are the competitors? Where are the customers? Where are the customers that are spending the most money at the store?

In a complete location analysis study, you might also consider other factors, including the average traffic flow near the new location, land costs, zoning concerns, and planning rules. 

Open Coffee.mxd under Spatial-part1.

The map contains three layers: Shops, Customers, and Streets. The Shops layer contains the locations of existing coffee shops. The Customers layer is not turned on; you will turn it on later.

Examine the locations of the existing shops. For this analysis, you will assume that any shops within 1 mile of each other will compete for customers. Potential sites for a new shop should therefore be more than 1 mile from any existing shops.

For this analysis you will follow the steps shown in the flow chart below.
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You will start the analysis by creating a surface representing the distance from the shops. You will then create a surface representing the density of customer spending. Finally, you will query the distance and density layers to find the areas that are a mile or more from existing shops and with high spending density.

In the Table of Contents, click Shops. From the Spatial Analyst menu, choose Distance, then click Straight Line.

The Straight Line dialog displays. For Distance to, make sure Shops is selected. Click OK.

A distance surface is created and added to the map. Areas shown in yellow and orange are close to the shops, while areas shown in purple and blue are farther from the shops.

Which areas do you think would be best for a new coffee shop?

Next, you will examine the customer locations. A new shop will be more successful if there are lots of customers (who spend lots of money) near the location.

Turn off the Distance to Shops layer and turn on the Customers layer. Right-click Customers and click Open Attribute Table.

Notice that the table has a SPENDING field, which indicates the amount of money customers spent over the last year. You will create a density surface of customer spending.

Close the table.

In the Table of Contents, click the Customers layer. From the Spatial Analyst menu, choose Density.

The Density dialog displays.

For Input data, make sure that Customers is selected. For Population field, click SPENDING. Click OK.

A spending density surface is created and added to the map.

Change the name of the layer to Spending density. Turn off the Shops, Customers, and Streets layers so that you can see the density layer more clearly.
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The dark blue areas have the greatest spending density of customers.

Turn on the Shops layer. Are there shops located in each of the dark blue areas? There is a dense area that doesn't have a shop in the southwest part of town.

You will finish the analysis by finding areas that are more than 1 mile (5,280 feet) from an existing shop and that are in a high spending density customer area.

From the Spatial Analyst menu, choose Raster Calculator. Create the following expression: ([Distance to Shops] > 5280) & ([Spending density] > .02).

Click Evaluate.

A new layer is added to the Table of Contents.

Change the name of the layer to Best locations.

Values of 1 are those areas where the distance to an existing coffee shop is greater than 1 mile and spending density is greater than 0.02. 

Use the layer properties dialog to remove the 0 values from the display as you did earlier.

The Best locations layer contains areas where you might focus efforts to find a new coffee shop location. Before selecting a final location, remember that there are many other factors to consider, including: the characteristics of existing shop neighborhoods, traffic counts, proximity to an interstate highway, income levels, population density, and age.

Part 2.1 Spatial Analyst for Finding Potential Sites for a New School in Stowe, Vermont
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Step 1. Input Datasets

Step 1.1. Examine the Data 

Add the following layers from Spatial-part2 directory to an empty ArcGIS map: elevation, landuse, rec_sites, roads, and schools. Selecting suitable operations to change symbols, colors, and classes for different layers such as the following figure: 
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Step 1.2 Setting the analysis properties.

Click Spatial Analyst -> Options -> Extent and set the Analysis extent to be "Same as Layer landuse" 

Click Spatial Analyst -> Options -> Cell Size to set the Cell size to be the "Same as Layer elevation" . Click OK to close Options dialog box.

Click the Layer dropdown arrow and click landuse and Histogram button (1)
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Display a histogram of landuse to see how many of cells there are for each type of land use.

Step 1.3. Creating a hillshade

The hillshade function calculates how each cell of a raster would appear if it were a surface illuminated by a light source. Click Spatial Analyst -> Surface Analysis -> Hillshade and select elevation as the input surface. A new hillshade layer is added to the map. This layer should be made permanent by right-clicking the hillshade layer and selecting "make permanent" and save to MyData 

Drag the hillshade layer below the landuse layer and make the landuse layer transparent (Click View -> Toolbars -> Effects and Adjust Transparency for landuse to 30%). 
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(Attention!!!! For those of you would like to challenge your capability, you should start from here by yourself, after you’ve done Step2 –Step4, then you compare with the steps or results below. You can find what you should do for Step 2, Step3, and Step4 from the workflow chart in page 11)

Step 2. Derive new datasets

Derive slope from elevation

The landarea being examined is mountainous. The school should be built on a relatively flat area of land. Click Spatial Analyst -> Surface Analysis -> Slope and set the input surface to elevation. Right-click the output layer in the table of contents and click Make Permanent and save to MyData

Derive distance from recreational sites

It is desirable to build the school close to a recreational site. Therefore a new raster layer will be constructed with cells colored based on their distance from a recreational site. 

Click Spatial Analyst -> Distance -> Straight Line and select rec_sites in the "Distance to:" dropdown. 

Derive distance from schools

Click Spatial Analyst -> Distance -> Straight Line and select schools in the "Distance to:" dropdown. 

Step 3. Reclassify the Datasets

The slope and derived datasets should be reclassified so that the numeric values stored in the cell are in the same range and so that desirable characteristics are assigned larger numbers. 

Reclassify distance to recreation sites

Using the same technique as above, assign 10 to areas closest to recreational sites, etc. Right-click the output layer in the table of contents and click Make Permanent and save to MyData.

Reclassify distance to schools

Using the same technique, you do not need to change any value, since you do not want to build a new school close to existing schools. Right-click the output layer in the table of contents and click Make Permanent and save to MyData.

Reclassify landuse

Reclassify landuse by Spatial Analyst -> Reclassify -> Input raster = landuse and set Agriculture to 10, Barren land to 6, Brush/Transitional to 5, Built up to 3 and Forest to 4. These values reflect the suitability for building on the types of land. Also, select the Water and Wetlands rows and click Delete Entries and click the Change missing values to NoData to remove these areas from consideration. Right-click the output layer in the table of contents and click Make Permanent and save to MyData.

Step 4. Weight and Combine Datasets

Since the datasets have a common scale for suitability, they can be combined to select the most suitable areas. It has been determined that the following weights should be assigned to the various selection criteria: 

	Distance to recreation sites
	50%

	Distance to schools
	25%

	Landuse
	12.5%

	Slope
	12.5%


Click Spatial Analyst -> Raster Calculator and enter the appropriate formula 
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To highlight the most desirable areas, right-click the new layer to select Properties and click Symbology -> Classified -> Classes (=10). Select the last 3 classes (the most suitable areas) and right-click to Properties for selected Colors and choose a bright color. Click Display NoData -> black.

Right-click the output layer in the table of contents and click Make Permanent and save to MyData, typing suitability and click Save. Save the project.
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Turn on the feature classes: schools, rec_sites, and roads. Do you think which area is the best location for the new school ?.

Part 2.2 Spatial Analyst for finding a road to the new school site
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Create the destination dataset if necessary. In this exercise,
the Destination is a point at a road junction.

Perform shortest path using the Distance and Dircction
datasets created from the cost weighted function.

Step 1: Create Source and Cost Datasets

Step 2: Cost Weighted Distance

Destination  Distance  Direction

Step 3: Shortest Path

)





(Attention!!!! For those of you would like to challenge your capability, you should start from here by yourself, by following Steps from the workflow chart. If you only follow the steps provided here without thinking, you will not get much out from the lab exercises)

Step 1. Creating source and cost datasets

1.1 Creating source datasets

Open the above project in ArcMap. Open ArcCatalog and find the Sptial-part2/MyData directory. Create a new Polygon shapefile called “School_site”. (Right click MyData -> New -> Shapefile). Assigned the coordinate system of NAD 1983 StatePlane Vermont FIPS 4400.prj to the new shape file (click Edit in spatial reference -> Select -> Projected Coordinate System -> State Plane -> NAD 1983). Drag and throw it to the ArcMap project. 

Area 1 is considered as the best site for the new school. So you will create a new school polygon in these site. Zoom in to area 1; Click View -> Toolbars -> Editor -> Editor dropdown arrow -> Start Editing. Select Task, Target as below:
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Draw a small polygon in this area, and click Stop Editing to save. 
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1.2. Creating cost dataset

Reclassify slope

Click Spatial Analyst -> Reclassify and select Slope as the input raster. Click Method -> Equal Interval and Classes -> 10. Assign the first "New value" to be 10 (least slope - most desirable), the next 9, etc. Leave NoData as NoData. Right-click the output layer in the table of contents and click Make Permanent and save to MyData.

Reclassify lanuse
Reclassify landuse by Spatial Analyst -> Reclassify -> Input raster = landuse and set Agriculture to 4, Barren land to 6, Brush/Transitional to 5, Built up to 9, Forest to 8, and Water to 10. High values indicate higher road-construction costs. Click Wetlands -> Delete Entries, check Change missing values to NoData. Click OK. Change NoData to White color. Right-click the output layer in the table of contents and click Make Permanent and save to MyData.

Combine datasets

Combine above two datasets into one, and rename it to Cost and make it permanent. Locations with low values (dark blue) will be the least costly to build a road through. Remove all layers except Cost, School_site, and Roads. 
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Step 2. Performing cost weighted distance

Click Spatial Analyst -> Distance -> Cost Weighted. Set Distance to School_site, Cost raster to Cost, and check Create direction, click OK.
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The Distance and Direction datasets are added to your ArcMap as layers. Rename them to Distance and Direction. 

Step 3. Performing shortest path

Add destination point shape file (in Spatial-part2) to your map. Click Spatial Analyst -> Distance -> Shortest Path. Set Path to Destination, Cost distance raster to Distance, Cost direction raster to Direction, Path type to For Each Cell, and Output features to your assigned place. Click OK.

The shortest path is calculated, and added to your ArcMap. Uncheck Cost, Distance, and Direction layers and Add Hillshade and landuse layers. Make the landuse 30% transparency overlaying the Hillshade layer. Zoom in to enlarge the new Path. Right click the Roads layer, click Properties -> Lables. Checking Label Features, Setting Label Field to STREET_NAM. Click OK. The Road names labeled on the map. 

Save your project to MyData.
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New Polygon for the new school
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